Digital Aquarium’s
Blender Introduction Workshop Guide for Novice Users

About Blender
Blender provides a broad spectrum of modeling, texturing, lighting, animation and video post-processing functionality in one package. Through it’s open architecture, Blender provides cross platform interoperability, extensibility, an incredibly small footprint, and a tightly integrated workflow.

Blender is one of the most popular Open Source 3D graphics application in the world. This is an introduction level workshop and meant for students who have no prior knowledge of the program. It teaches the blender interface, object manipulation, lighting, using the camera,

Blender Interface

The user interface is the vehicle for two-way interaction between the user and the program. The user communicates with the program via the keyboard and the mouse, and the program gives feedback via the window system.

The interface can be broken down into several key areas: Windows, Contexts, Panels, and Buttons (controls). For example, The Button window contains Context buttons which show different groups of Panels and the Panels each show groups of Buttons.
The default Blender scene shows the screen you should get after starting Blender for the first time. By default it is separated into three windows:

Three Window types are provided in Blender’s default screen:

**3D View**- Provides a graphical view into the scene you are working on. You can view your scene from any angle with a variety of options; see Manual/Part I/Navigating in 3D Space for details. Having several 3D Viewports on the same screen can be useful if you want to watch your changes from different angles at the same time.

**Buttons Window**- Contains most tools for editing objects, surfaces, textures, Lights, and much more. You will need this window constantly if you don’t know all hotkeys by heart. You might indeed want more than one of these windows, each with a different set of tools.

**User Preferences (Main menu)**- This window is usually hidden, so that only the menu part is visible - see Manual/Part I/The Vital Functions -> User preferences and Themes for details. It's rarely used though, since it contains global configuration settings. However, the header is frequently used because it provides the only access to a full File menu and to the Add menu.
This section tells you how to navigate around in your virtual world using the unique Blender interface. Using Blender, you create a world that exists in four dimensions:

- Left-right, commonly called the “x” axis
- Forward-backward, commonly called the “y” axis
- Up-down, commonly called the “z” axis
- Time-sensitive, through animated objects, materials, and motion captured in frames

Blender lets you work in three-dimensional space, but our monitor screens are only two-dimensional. To be able to work in three dimensions, you must be able to change your viewpoint as well as the viewing direction of the scene. This is possible in all of the 3D

### View Menu

You can select the viewing direction for a 3D Viewport with the View Menu entries (A 3D Viewport’s view menu) or by pressing the hotkeys:

- NumPad 3 for SIDE
- NumPad 1 for FRONT
- NumPad 7 for TOP

You can select the opposite directions if you hold the Control key while using the same numpad shortcuts.

Finally, NumPad 0 gives access to the “Camera” viewpoint.

### Views

- Side - numpad 3
- Front - numpad 1
- Top - numpad 7
- Camera - numpad 0
The 3D Viewport

**Rotating the View**

There are two ways you can rotate your view.

**MMB (Middle Mouse Button)** - If you hold down the middle mouse button and drag you can freely rotate your view in all directions.

**Numpad 2, 4, 6, and 8** - By pressing these numpad keys, you can rotate your view in small increments.

**Panning the View**

Panning lets you move your view up, down, and side to side.

**Shift + MMB** - While holding shift and the middle mouse button, you can freely pan your view in all directions.

**Shift + Numpad 2, 4, 6, and 8** - By holding shift and pressing these numpad keys, you can pan your view in small increments.

**Zooming the View**

There are several ways to zoom in and out.

**MW (Mouse Wheel)** - Move the mouse wheel back and forth to zoom in and out.

**Numpad (+) and (-)** - By pressing the numpad keys, you can zoom in and out in small increments.

**CTRL + ALT + LMB (left Mouse Button)** - If you don’t have a middle mouse button, you can zoom in and out by holding control, Alt, and the Left mouse button and dragging the mouse.
Perspective

Each 3D Viewport supports two different types of projection. These are demonstrated in (Orthographic (left) and Perspective (right) projection).

Our eye is used to perspective viewing because distant objects appear smaller. Orthographic projection often seems a bit odd at first, because objects stay the same size independent of their distance; It is like viewing the scene from an infinitely distant point. Nevertheless, orthographic viewing is very useful (it is the default in Blender and most other 3D applications), because it provides a more “technical” insight into the scene, making it easier to draw and judge proportions. To change the projection for a 3D Viewport, choose the View>Orthographic or the View>Perspective Menu entry (A 3D Viewport’s view menu.). The hot-key NumPad 5 toggles between the two modes.

Objects Manipulation

The geometry of a scene is constructed from one or more Objects. For example Lamps, Curves, Surfaces, Cameras, Meshes, and the basic objects. Each object can be moved, rotated and scaled to the user’s preference. The default 3d view has three different objects: a lamp, a camera, and a 3d mesh.

Types of Objects - The objects listed here are the most common objects you will be using however there are more.

Lamps - These are what your are seeing. There are 5 types of lamps that light your scene in different ways.

Camera - When you render a scene, you need to have a camera to do so. Whatever you point your camera at is what the image will look like once rendered.

Meshes - Meshes are what you see in a 3d scene. Without them, there is nothing to light or render. Modeling is associated with creating and editing meshes.
Objects Manipulation

Adding and Deleting Objects

Adding Objects - There are different ways to add objects but the easiest is to use the toolbox. To bring up the toolbox, press the spacebar while your mouse is hovering over the 3d viewport. With the mouse cursor, hover over add to bring out the submenu. You can then select the different types of objects to add to your scene.

Deleting Objects - To delete any object, press the x key while the object is selected. After the small menu pops up to confirm, press ok with the cursor to delete.

Object Manipulation

There are many things you can do with the selected object within your virtual world. You can twist it, make it bigger or smaller, spin it around, change its shape, and so on. This section tells you how to do these things to your objects.

Menu Options

With an object selected in a 3D view, the menu bar shows the selections View, Select and Object. Click the Object selection to manipulate the object. The menu that pops up has the option Transform. Hovering over Transform pops up a submenu, showing you selections (and hot keys on the right) for manipulating the objects.
Object Manipulation

**Grab/Move**
- **Hotkey:** G
- **Menu:** Object/Mesh/etc → Transform → Grab/Move
- **Description:** One of the fastest ways to move things in 3D space is with G. Pressing the hotkey will enter the ‘grab/move’ transformation mode where the selected object or data is moved according to the mouse pointer’s location. The distance from the mouse pointer to the manipulated object has no effect.
  - **LMB** Confirm the move, and leave the object or data at its current location on the screen
  - **MMB** Constrain the move to the X, Y or Z axis.
  - **RMB** or Esc Cancel the move, and return the object or data to its original location.

**Rotate**
- **Hotkey:** R
- **Menu:** Object/Mesh/etc → Transform → Rotate
- **Description:** Pressing R will enter the ‘rotate’ transformation mode where the selected object or data is rotated according to the mouse pointer’s location. This mode uses the angle from the pivot point to the mouse pointer as the angle for rotation, so moving the mouse further from the object/data will give more fine-grained precision (i.e. the mouse movement will affect the rotation less, for the same mouse distance moved).
  - **LMB** Confirm the rotation, and leave the object or data at its current rotation on the screen
  - **MMB** Constrain the rotation about the X, Y or Z axis.
  - **RMB** or Esc Cancel the rotation, and return the object or data to its original rotation

**Scale**
- **Hotkey:** S
- **Menu:** Object/Mesh/etc → Transform → Scale
- **Description:** Pressing S will enter the ‘scale’ transformation mode where the selected object or data is scaled inward or outward according to the mouse pointer’s location. The object/data’s scale will increase as the mouse pointer is moved away from the pivot point, and decrease as the pointer is moved towards it. If the mouse pointer crosses from the original side of the pivot point to the opposite side, the scale will continue in the negative direction, making the object/data appear flipped. The precision of the scaling is determined by the distance from the mouse pointer to the object/data when the scaling begins.
  - **LMB** Confirm the scale, and leave the object or data at its current scale on the screen
  - **MMB** Constrain the scaling to the X, Y or Z axis.
  - **RMB** or Esc will cancel the scale, and return the object or data to its original scale
  - **Alt S** Scales along the selected normal direction
Lighting is a very important topic in rendering, standing equal to modelling, materials and textures. The most accurately modelled and textured scene will yield poor results without a proper lighting scheme, while a simple model can become very realistic if skillfully lit. Lighting, sadly, is often overlooked by the inexperienced artist who commonly believes that, since real world scenes are often lit by a single light (a lamp, the sun, etc.) A single light will also do in computer graphics. This is false because in the real world even if a single light source is present, the light shed by such a source bounces off objects and is re-irradiated all over the scene, making shadows soft and shadowed regions not pitch black, but partially lit.

**Lamp**

The lamp is an omnidirectional point of light, that is, a point radiating the same amount of light in all directions. It’s visualized by a plain, circled dot, (Lamp Light).

**Spot Light**

A Spot lamp emits a cone shaped beam of light from the tip of the cone, in a given direction.

**Area Light**

The Area lamp simulates light originating from surface (or surface-like) emitters, for example, a TV screen, your supermarket’s neon lights, a window or a cloudy sky are just a few types. The area lamp produces shadows with soft borders by sampling a lamp along a grid the size of which is defined by the user. This is in direct contrast to point-like artificial lights which product sharp borders.
**Hemi Lamp**

The Hemi lamp provides light from the direction of a 180° hemisphere, designed to simulate the light coming from a heavily clouded or otherwise uniform sky. In other words it is a light which is shed, uniformly, by a glowing dome surrounding the scene (Hemi Light conceptual scheme). The hemi lamp is represented with four arcs, visualizing the orientation of the hemispherical dome, and a dashed line representing the direction in which the maximum energy is radiated, the inside of the hemi-

**Sun Lamp**

A Sun lamp provides light of constant intensity emitted in a single direction. In the 3D view the Sun light is represented by an encircled black dot with rays emitting from it, plus a dashed line indicating the direction of the light. This direction can be changed by rotating the sun lamp, as any other object, but because the light is emitted in a constant direction, the location of a sun lamp does not affect the rendered result.
Using the Camera

Behaving much like a real life camera, the Camera is used to frame your scene for rendering images.

The View >> Camera Menu entry sets the 3D Viewport to camera mode (Hotkey: NumPad 0). The scene is then displayed as it will be rendered later: the rendered image will contain everything within the outer dotted line. Zooming in and out is possible in this view, but to change the viewpoint, you have to move or rotate the camera.

Edit Panel
Cameras are invisible in a scene; they are never rendered, so they don’t have any material or texture settings. However, they do have Object and Editing setting panels available which are displayed when a camera is the active (selected) object.
Rendering

Rendering is the final process of CG (short of post processing, of course) and is the phase in which the image corresponding to your 3D scene is finally created. Rendering is a CPU-intensive process. You can render an image on your computer, or use a render farm which is a network of PC's that each work on a different section of the image or on different frames.

The rendering of the current scene is performed by pressing the big **RENDER** button in the Render panel, or by pressing **F12** (you can define how the rendered image is displayed on-screen in the Render Output Options).

The **rendering buttons window** is accessed via the Scene Context and Render Sub-context (F10 or the button). The rendering Panels and Buttons are shown in Rendering Buttons. These buttons are organized into panels, which are:

**Output** - controls the output of the render pipeline
**Render Layers** - controls which layers and passes to render
**Render** - controls the actual rendering process of a still shot
**Anim** - controls the rendering of a series of frames to produce an animation
**Bake** - pre-computes certain aspects of a render
**Format** - controls the format and encoding of the picture or animation
**Stamp** - stamps the frames with identifying and configuration control item information

**Saving Your Image**
Rendered images can be saved by pressing F3 or via the File->Save Image menu using the output option in the Output panel. Animations are saved according to the format specified, usually as a series of frames in the output directory. The image is rendered according to the dimensions defined in the Format Panel (Image types and dimensions.).

**Links and Resources**

It wouldn’t be possible to fit all there is to know about blender into this workshop guide. Therefore, here is a list of great resources to help you with using blender:

**Blender Website**
www.blender.org

**Blender Manual** - This is the official manual and can be found within the blender website: http://wiki.blender.org/index.php/Manual